Forum

Notifications
Clear all

Blank Screen


(@jmconnected1)
New Member
Joined: 3 months ago
Posts: 3
Topic starter  

My jeep sit for 3 weeks andd the battery went dead. I jumped it and now the Carobotor dash is black.  I can only see the gas gauge on the right and the temp on the left. Has anyone ever experienced this or know how to fix it?

 

 

 


Quote
(@jp4102)
Active Member
Joined: 4 months ago
Posts: 10
 

#1 Don’t ask Carobotor for help. They’re useless and 99% of issues go unanswered because their customer service is horrible.

#2 Try turning your dimmer switch all the way off and on.  

I experience it all the time for no apparent reason.

This post was modified 3 months ago 2 times by JP4102

ReplyQuote
(@jmconnected1)
New Member
Joined: 3 months ago
Posts: 3
Topic starter  

ok, i'll try that.  

 

Thanks.

 


ReplyQuote
(@kyq83)
New Member
Joined: 1 month ago
Posts: 2
 

Hi,

I have same problem 😕. 


hemified liked
ReplyQuote
(@kyq83)
New Member
Joined: 1 month ago
Posts: 2
 

It's OK

I drive for 100km from my work to home and turn off jeep about 2 hours then it's work normally.


hemified liked
ReplyQuote
(@jmconnected1)
New Member
Joined: 3 months ago
Posts: 3
Topic starter  

@jp4102

your right, i sent Carobotor a message the day I posted this and they have still not responded back.

It started working again after I charged it and drove it about 50 miles.  It still reads in kilometers and want save back MPH.  I gave up and sent it back to the people who installed it.  Thanks For the help.


ReplyQuote
Share:
Scroll to Top